You need to have Windows 7 pro or higher operating system.

.Net Framework 4.5 will be downloaded and installed automatically when SambaPOS V5 installation begins, if you have internet in your PC.

NoYes (No Ratings Yet)
Loading...