Software Requirements

SambaPOS runs on the Windows 7 pro or higher operating systems. Windows XP is not compatible with SambaPOS.

You need to install .Net Framework 4.5 for SambaPOS V5 Pro. If you don’t have it in your PC, it will be installed automatically when SambaPOS V5 setup begins. You need to have internet to download.

SambaPOS V5 Pro needs Microsoft SQL. SQL LocalDB can be used for a simple setup. You can select to install it when setup begins, it will be downloaded automatically. Don’t forget that you can use only one PC with LocalDB, you can not connect any client. Please prefer Microsoft SQL Express Edition + Management Studio if you need to use more than one PC in a network. SQL version must be minimum SQL Express Edition 2012.

Hardware Requirements

You need to use at least Intel Celeron J1900 CPU, 4 GB Ram and prefer 64 GB SSD. Please don’t prefer Atom CPU.

Monitors should have minimum 1024×768 resolution. You can also prefer HD or FULLHD monitors.

SambaPOS can be used with touchscreens. SambaPOS is compatible with all type of touchscreens. You can also prefer all in one pc.

Printer Requirements: All types of ESC/POS and dot-matrix featured printers can be used.

Tablet Requirements: All types of Windows based tablets can be used. Operating system must be minimum Windows 7. Android tablets can be used with Mobile Client app. Android tablets must have minimum Android 4.4 version.

Caller ID Devices: SambaPOS is compatible with CIDShow and Hugin. You can prefer a modem which has Conexant Chipset and Caller ID featured fax modem.

Scales: Cas ER Junior model, TEM EGE are compatible with SambaPOS. All types of scales connecting by COM port can be used with SambaPOS if you install Scale Module.

Barcode Reader/Printer: All types of barcode, QR Code readers can be used.

Cash Drawers: All types of cash drawers can be used if they connect to printer with RJ11.

NoYes (No Ratings Yet)
Loading...